Iowa 2 and Iowa 3 - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 04:31 UTC

Identified

We are currently experiencing a partial outage at our Iowa facility due to a transformer issue affecting a section of the site. Our onsite team is working to restore power, with an estimated resolution early next week.

We appreciate your patience and understanding.
Posted Aug 24, 2025 - 08:53 UTC

Investigating

We are currently investigating this issue.
Posted Aug 23, 2025 - 07:09 UTC
This incident affected: Iowa 2, United States and Iowa 3, United States.