Iowa 4 - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 04:58 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 24, 2025 - 04:58 UTC

Identified

Due to peak grid demand, the Midcontinent Independent System Operator (MISO) has issued a notice to curtail. The mining facility will curtail between the hours of 4PM and 10PM CST on Sunday, June 22. Our technicians will bring miners back online as soon as possible. Thank you for your patience and understanding.
Posted Jun 23, 2025 - 01:38 UTC
This incident affected: Iowa 4, United States.