Minnesota 2 - Maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 05:59 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 01, 2025 - 06:50 UTC

Identified

The Facility is undergoing routine maintenance. During this process, small-scale intermittent downtime may occur.

The onsite team will bring the miners back online as soon as the maintenance is completed. We appreciate your patience and cooperation.
Posted Sep 18, 2025 - 17:21 UTC
This incident affected: Minnesota 2, United States.