Iowa 2/3 - Power Curtailment
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Oct 12, 2024 - 00:03 UTC
Identified
Iowa 2/3 facility will be curtailing from 3pm to 6pm today, October 11, 2024 (CDT). We appreciate your patience and cooperation.
Posted Oct 11, 2024 - 04:44 UTC
This incident affected: Iowa 2, United States.