Indiana 2 Power Maintenance
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted May 18, 2023 - 21:37 UTC
Identified
The facility power service provider has requested a power down for scheduled maintenance.
- This power down will start sometime between the hours of 8:00 am and 9:00 am EST.
- They do estimate this power down to last between 4 and 5 hours.
Posted May 18, 2023 - 12:46 UTC
This incident affected: Indiana 2, United States.