Texas 4 - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Oct 03, 2023 - 03:34 UTC

Investigating

We are currently investigating this issue.
Posted Oct 03, 2023 - 02:57 UTC