North Dakota - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted May 27, 2026 - 13:04 UTC

Identified

Due to elevated local temperatures, the facility has partially curtailed between the hours of 11:30 AM and 9:00 PM Central Time, May 26, 2026. Not all miners are affected. If your miner is offline and remains offline after this timeline, please submit a support request, and our Remote Monitoring Team will investigate further.

Thank you for your kind understanding.
Posted May 26, 2026 - 17:12 UTC
This incident affected: North Dakota, United States.