Iowa 2 - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Aug 01, 2025 - 07:33 UTC

Investigating

Iowa 2 is experiencing a partial outage now.

We are currently investigating this issue.
Posted Jul 29, 2025 - 16:56 UTC
This incident affected: Iowa 2, United States.