Ohio 2 (OH2) - Partial Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Sep 23, 2024 - 13:18 UTC
Identified
The C1 container's switchgear has tripped and is awaiting repair. We appreciate your patience and understanding as we work to resolve this as soon as possible.
Posted Sep 09, 2024 - 10:17 UTC
This incident affected: Ohio 2, United States.