Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 21, 2025 - 22:00 UTC
Scheduled
Our Iowa 2 and Iowa3 facilities will be curtailing today, January 21, 2025. Sites 1 and 3 will be curtailing for 1 hour from 6PM to 7PM CST. Site 2 will be curtailing for 6 hours from 4PM to 10PM CST. The onsite team will bring the miners back online as soon as power is fully restored. We appreciate your patience and cooperation.
Posted Jan 21, 2025 - 15:24 UTC
This scheduled maintenance affected: Iowa 2, United States and Iowa 3, United States.