Ohio 2 - Maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 22:05 UTC

Investigating

Our Ohio 2 facility will be shutting down a portion of the site (C6) for maintenance. The onsite team will bring the miners back online as soon as power is fully restored. We appreciate your patience and cooperation.
Posted Mar 18, 2025 - 16:05 UTC
This incident affected: Ohio 2, United States.