Indiana 1 - Site Maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Feb 05, 2025 - 09:08 UTC

Identified

Our Indiana 1 facility will be shutting down a portion of the site for maintenance. The onsite team will bring the miners back online as soon as power is fully restored. We appreciate your patience and cooperation.
Posted Feb 04, 2025 - 14:08 UTC
This incident affected: Indiana 1, United States.