Iowa 2 and Iowa 3 - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 05:03 UTC

Update

Iowa 2 and Iowa 3 is currently curtailing. The onsite team will bring the miners back online as soon as power is fully restored.
We appreciate your cooperation.
Posted Jun 18, 2025 - 02:23 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 18, 2025 - 02:21 UTC
This incident affected: Iowa 2, United States and Iowa 3, United States.