OH2 Planned Site Outage

Incident Report for Compass Mining

Resolved

Sorry for the delay; power has been restored to the site.
Posted Sep 19, 2023 - 18:07 UTC

Identified

We have a scheduled site shutdown from 9am EST to 12pm EST. A crane will be operating on site and power will be shutdown for safety.
Posted Sep 19, 2023 - 12:20 UTC
This incident affected: Ohio 2, United States.