(55x) Minnesota Electrical Upgrades
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Jun 09, 2023 - 15:07 UTC
Identified
The site is currently undergoing electrical upgrades to several of the containers. Downtime is expected throughout the week.
Posted May 31, 2023 - 13:43 UTC
This incident affected: Minnesota, United States.