Minnesota 1 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted May 15, 2025 - 04:12 UTC

Identified

The Minnesota facility will undergo another curtailment today, May 14th, from 2:00 PM to 6:00 PM Central Time. This curtailment may potentially extend further into the evening due to the hot weather. The onsite team will restore the miners as soon as power returns.

Thank you for your patience and understanding.
Posted May 14, 2025 - 15:03 UTC
This incident affected: Minnesota, United States.