Iowa 2 and Iowa 3 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 05:24 UTC

Identified

The local power authority has issued a notice to curtail. The mining facility will power down between the hours of 6:00 PM CDT – 8:00 PM CDT, June 29th. Our technicians will bring miners back online as soon as the curtailment period is complete. Thank you for your patience and understanding.
Posted Jun 29, 2025 - 01:24 UTC
This incident affected: Iowa 2, United States and Iowa 3, United States.