Indiana 2 Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 08:40 UTC

Identified

The local power authority has issued a notice to curtail. The mining facility will power down between the hours of 2:30 PM and 5:00 PM EST, August 04, 2025. Our technicians will bring miners back online as soon as the curtailment period is complete. Thank you for your patience and understanding.
Posted Aug 04, 2025 - 14:01 UTC
This incident affected: Indiana 2, United States.