Texas 3 Network Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted May 22, 2023 - 15:59 UTC

Identified

The facility is currently experiencing a network outage. Crews are actively working on resolution.
Posted May 19, 2023 - 18:13 UTC