Iowa 4 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 06:03 UTC

Identified

The local power authority has issued a notice to curtail. The mining facility will power down between 2:00 PM to 10:00 PM Central Time on July 1st.

Our technicians will bring miners back online as soon as the curtailment period is complete. Thank you for your patience and understanding.
Posted Jul 01, 2025 - 12:39 UTC
This incident affected: Iowa 4, United States.