Minnesota 1 - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 17:26 UTC

Investigating

The Minnesota facility will curtail from 9 am - 11 am and again from 5 pm - 7 pm central time. The onsite team will restore the miners as soon as power returns. Thank you for your patience.
Posted Mar 31, 2025 - 14:51 UTC
This incident affected: Minnesota, United States.