Manitoba 7 Network Maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Sep 21, 2023 - 21:56 UTC

Investigating

The facility will be down for around an hour while techs on site perform network maintenance.
Posted Sep 21, 2023 - 17:46 UTC
This incident affected: Manitoba 7, Canada.