Indiana 1 - Maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jul 07, 2026 - 12:59 UTC

Identified

Our Indiana 1 facility has identified units with PDU issues that are currently being repaired. The onsite team will bring the affected miners back online as soon as this is resolved. We appreciate your patience and cooperation.
Posted Jul 06, 2026 - 13:11 UTC
This incident affected: Indiana 1, United States.