Iowa 3 - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 13:41 UTC

Investigating

We are currently investigating this issue.
Posted Jul 15, 2025 - 11:18 UTC
This incident affected: Iowa 3, United States.