Ohio 2 - Partial Outage

Incident Report for Compass Mining

Monitoring

Site Maintenance Update: Electrical contractors have begun their work on the transformer that feeds C2. Work is expected to last 2.5 weeks. We appreciate your patience and cooperation during this time.
Posted Aug 25, 2025 - 22:47 UTC

Identified

The Ohio 2 facility's (C2) container is still experiencing a transformer issue that is being resolved. Our team has sent out incident emails regarding the concern and offered temporary units in the meantime. Our on-site technicians are working diligently to resolve the problem. We appreciate your patience and cooperation during this time.
Posted Jul 07, 2025 - 06:03 UTC
This incident affects: Ohio 2, United States.