Iowa 3 - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 15:58 UTC

Identified

Site 1 is currently experiencing a partial outage. Our on-site technicians are working diligently to resolve the problem. We appreciate your patience and cooperation during this time.
Posted Jun 12, 2025 - 15:09 UTC
This incident affected: Iowa 3, United States.