(50x) Texas 1 Partial Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Mar 17, 2023 - 15:28 UTC
Identified
A small subset of units are affected by an electrical component failure. We expect this issue to be resolved by end of day 3/17.
Posted Mar 16, 2023 - 22:20 UTC
This incident affected: Texas 1, United States.