Iowa 4 - Site Maintenance

Incident Report for Compass Mining

Update

Iowa 4 experienced electrical disruptions last week caused by water intrusion, impacting several containers. Our team is actively working with specialists to seal identified leaks and install protective awnings to prevent future issues. Despite ongoing weather challenges, repair efforts continue. We will provide further updates once a clear restoration timeline is established.
Posted Aug 04, 2025 - 14:52 UTC

Identified

Operations at the facility were recently interrupted due to electrical issues encountered over the weekend. Maintenance activities are currently underway to restore the site to full hashrate.
Posted Jul 28, 2025 - 13:36 UTC
This incident affects: Iowa 4, United States.