Minnesota 1 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 14:22 UTC

Identified

Due to the ongoing extreme heatwave impacting the site, the Minnesota facility will undergo a mandatory curtailment today, June 24th, from 11:00 AM to 10:00 PM Central Time. This schedule is subject to change based on evolving grid demands.

Our onsite team is prepared to promptly restore operations and bring the miners back online as soon as power becomes available.

We sincerely appreciate your continued patience and understanding during this time.
Posted Jun 24, 2025 - 10:03 UTC
This incident affected: Minnesota, United States.