North Dakota - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 12:33 UTC

Identified

Due to elevated local temperatures, the facility has partially curtailed today, July 25, 2025. Not all miners are affected. If your miner is offline and remains offline after this timeline, please submit a support request, and our Remote Monitoring Team will investigate further.

Thank you for your patience and understanding.
Posted Jul 25, 2025 - 19:15 UTC
This incident affected: North Dakota, United States.