Texas 6 - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 21, 2025 - 05:19 UTC

Identified

The Texas 6 facility is currently undergoing a curtailment. The onsite team will bring the miners back online once power is fully restored. We appreciate your patience and cooperation.
Posted Jun 19, 2025 - 22:01 UTC
This incident affected: Texas 6, United States.