Texas 5 - Power Curtailment
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Nov 18, 2024 - 00:55 UTC
Identified
The Texas 5 facility is currently curtailing. The onsite team will bring the miners back online as soon as power is fully restored. We appreciate your patience and cooperation.
Posted Nov 17, 2024 - 23:14 UTC
This incident affected: Texas 5, United States.