Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 23, 2025 - 22:00 UTC
Scheduled
Our Iowa 2 and Iowa 3 facilities will be curtailing today, January 23, 2025. Site 1 and Site 3 will be offline from 5PM to 8PM CST, while Site 2 will have a 5-hour curtailment from 4PM to 9PM CST. The onsite team will bring the miners back online as soon as power is fully restored. We appreciate your patience and cooperation during this time.
Posted Jan 23, 2025 - 14:12 UTC
This scheduled maintenance affected: Iowa 2, United States and Iowa 3, United States.