North Dakota - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted May 11, 2026 - 17:57 UTC

Update

We’d like to let you know that the onsite team is still investigating the issue. Thank you for your patience.
Posted May 01, 2026 - 20:46 UTC

Identified

Due to a sudden power outage caused by a faulty oil temperature gauge at the South ARC substation, 68 miners went offline. Our onsite team is investigating the issue and will share updates as more information becomes available.

Thank you for your patience and understanding.
Posted Apr 28, 2026 - 15:28 UTC
This incident affected: North Dakota, United States.