Iowa 3 - Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Nov 12, 2024 - 22:52 UTC
Investigating
Iowa 3 is currently experiencing an outage. Our on-site team will bring the miners back online as soon as the outage is resolved. We appreciate your cooperation.
Posted Nov 12, 2024 - 18:27 UTC
This incident affected: Iowa 3, United States.