Iowa 2 and Iowa 3 - Curtailment
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Jan 20, 2025 - 19:54 UTC
Identified
Iowa 2 and Iowa 3 are partially curtailing today at Site 1 and 3 from 5AM to 8AM CST. The onsite team will bring the miners back online as soon as power is fully restored. We appreciate your patience and cooperation.
Posted Jan 20, 2025 - 11:22 UTC
This incident affected: Iowa 1, United States and Iowa 3, United States.