Texas 3 - Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 14:02 UTC
Investigating
We are currently investigating this issue.
Posted Apr 25, 2024 - 23:10 UTC
This incident affected: Texas 3, United States.