Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 30, 2024 - 17:30 UTC
Scheduled
Ohio 2 will be curtailing from 1:30 pm - 8:00 pm EST today. The onsite team will bring the miners back online as soon as power is fully restored. We appreciate your cooperation.
Posted Aug 30, 2024 - 15:48 UTC
This scheduled maintenance affected: Ohio 2, United States.