Minnesota 1 - Power Curtailment

Incident Report for Compass Mining

Resolved

We are continuing to work on a fix for this issue.
Posted Nov 28, 2023 - 12:20 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 28, 2023 - 12:19 UTC

Identified

The Minnesota facility is currently curtailing. The onsite team will bring on the miners once the power has been fully restored.
We appreciate your cooperation.
Posted Nov 27, 2023 - 16:03 UTC
This incident affected: Minnesota 1, United States.