Texas 6 - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 06:11 UTC

Identified

The Texas 6 site has curtailed for 4CP peak demand.

Power will be restored by onsite technicians as soon as possible.
Posted Jun 18, 2025 - 21:10 UTC
This incident affected: Texas 6, United States.