Minnesota 1 - Site Maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 05:59 UTC

Identified

The Minnesota 1 facility will be undergoing network infrastructure upgrades, which may result in intermittent downtime during the maintenance period.

Our onsite team is committed to restoring affected miners promptly once the upgrades are complete. We sincerely appreciate your patience and understanding
Posted Oct 15, 2025 - 05:58 UTC
This incident affected: Minnesota 1, United States.