Manitoba 2 Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Nov 29, 2023 - 13:01 UTC

Investigating

An outage has occurred at our Manitoba 2 location. Site operators will be on site shortly to investigate.
Posted Nov 29, 2023 - 01:55 UTC
This incident affected: Manitoba 2, Canada.