Iowa 2/3 - Power Curtailment
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Nov 26, 2024 - 16:07 UTC
Identified
Please be advised that a curtailment will take place on Tuesday, November 26, from 6:00 AM to 9:00 AM Central Time. We appreciate your understanding and cooperation during this time.
Posted Nov 26, 2024 - 07:15 UTC
This incident affected: Iowa 2, United States.