Minnesota 1 - Secheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 12:13 UTC

Identified

The Minnesota facility will undergo a scheduled curtailment today, June 16th, from 2:00 PM to 6:00 PM Central Time.

There is a slight possibility that the curtailment may be extended. Once power is restored, the onsite team will promptly bring the miners back online. We appreciate your patience and understanding.
Posted Jun 16, 2025 - 16:27 UTC
This incident affected: Minnesota, United States.