Indiana 2 Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Oct 03, 2023 - 04:26 UTC

Investigating

We are currently investigating this issue.
Posted Oct 02, 2023 - 18:44 UTC
This incident affected: Indiana 2, United States.