Nevada 1 Temp Miners - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Oct 03, 2023 - 01:32 UTC

Investigating

The facility hosting the Nevada 1 temp miners is currently curtailing due to grid demands.
Posted Oct 02, 2023 - 19:31 UTC