Texas 4 - Partial Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Mar 31, 2023 - 09:58 UTC
Update
Partial curtailment is now occurring due to volatile energy prices.
Posted Mar 28, 2023 - 00:20 UTC
Investigating
An electrical issue has affected all miners in Building 14. An electrician is working to resolve this issue. Miners will be brought back online as soon as possible.
Posted Mar 24, 2023 - 06:41 UTC
This incident affected: Texas 4, United States.