Minnesota 1 - Power Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted May 29, 2026 - 15:11 UTC

Update

Partial power has been successfully restored at the site. The required parts to fully energize the remaining sections have been ordered, with an expected lead time of 1–2 weeks. Further updates will be provided as progress continues. Thank you for your patience and understanding.
Posted May 19, 2026 - 13:37 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 18, 2026 - 05:51 UTC

Identified

The Minnesota 1 site is currently experiencing electrical issues impacting the entire facility. Repair work is actively underway, and further updates will be provided as progress continues.
Posted May 15, 2026 - 05:26 UTC
This incident affected: Minnesota 1, United States.