Ohio 2 - Maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted May 19, 2025 - 12:49 UTC

Identified

Our Ohio 2 facility has ongoing maintenance on a portion of the site (C6), doing fan motor repairs and heat containment. Other containers (C1 & C10) are also undergoing electrical inspection and fuse replacement. The onsite team will bring the miners back online once power is fully restored. We appreciate your patience and cooperation.
Posted May 16, 2025 - 16:28 UTC
This incident affected: Ohio 2, United States.