Iowa 2 and Iowa 3 - Partial Outage

Incident Report for Compass Mining

Identified

The issue has been identified at Site 1 and a fix is being implemented.
Posted Mar 28, 2025 - 16:00 UTC

Investigating

We are currently investigating this issue.
Posted Mar 28, 2025 - 07:25 UTC
This incident affects: Iowa 2, United States and Iowa 3, United States.